mg/sulfur ?

Discussion in 'Sick Plants and Problems' started by Don pinky, Sep 13, 2009.

  1. day time temp - 75 f
    night 65 f

    Sativa blue dream
    1 1/2 months old from clone

    1. She started showing very light green new growth starting from the base of the steam progressing to the tips.

    2. There were also a few rust colored spots on the lower fan leafs - none on the new growth. - this lead me to believe it was a mg deficiency.

    3. The outer edges around the newer leafs are a darker green , but most of the leaf is a light yellow/green color, a lot of discoloring is going on.


    Picture 2 is what i'm worried about...it seemed like a mg deficiency but even after a cal/mg/iron supplement she seems not not be getting better.

    I dont think she has been overfed but could this be because of a lockout? soil tester read around 6.5 but it is a piece of crap.

    i dont want this to progress much longer any help would be greatly appreciated!!
    [​IMG][/img]
    [[​IMG][​IMG][​IMG]
     
  2. Deficiencies of the major elements, (N,P, and K) will start at the bottom of the plant and work upwards. Micro-element deficiencies usually show at the area of new growth/shoots. I would flush the plant with clean water, let it dry out for a couple of days, and start adding nutes back at 1/3 or 1/2 strength. You should see improvement within a week or so. And be careful about over-watering. Make sure the soil is dry down about 2" inside the pot before watering.
     
  3. #3 Don pinky, Sep 15, 2009
    Last edited by a moderator: Sep 15, 2009
    I'm aware of the immobile/mobile nutrients and what growth area it effects.
    I did flush about a week ago and no signs of it getting better.
    I'm just stummped because i cant find any pics/ anywhere where people have this problem..Thats why im thinking a nutrient burn, but im really not sure
     
Loading...

Share This Page