Google SSL

Discussion in 'Silicon (v)Alley' started by Hello there!, Aug 12, 2011.

  1. Wtf is with the new encrypted Google? I can't do squat on it. Every time I click a link, it'll have the URL in the browser, but just bring me back to the encrypted home page. Same thing with the images. Is there any way to get around this?
  2. Get rid of.the "s" in the https in the URL bar
  3. What browser are you using? Works fine for me in Chrome.

    Well that defeats the point and your traffic is once again unencrypted. Working around the issue is easy, but it's not as if he ended up on the Google SSL Beta by accident.
  4. Firefox.

    And actually, it was on accident. I never changed anything, it just happened. Google won't let me browse normally, when I try getting rid of the s and the 'encrypted' part of the URL, nothing happens.
  5. #5 glazedKnuckles, Aug 13, 2011
    Last edited by a moderator: Mar 15, 2016
    Ohh I didn't know what he was going for
  6. Hmm thats weird, it works for me in Firefox on Linux
  7. LOL guess I was wrong.

    Does the same thing happen in IE? If not, I would try resetting everything in Firefox: preferences
  8. It works fine on IE! But I hate it, it's so slow... I tried resetting everything.. tried changing my Google account settings, tried signing out of my account, cleared all the caches and history or whatever, and it's still doing it! Even when I try to click 'Learn about Google SSL' it takes me back to the main page. :mad::mad::mad:

Share This Page