G Pen Help!!!!! PLEASE!!!

Discussion in 'Vaporizers' started by TrippyAssFiggs, Aug 15, 2012.

  1. I just got my G Pen today so I'm not sure what this means but everytime I screw on the Gtank and try to hit it, it's like it doesn't even heat up n make the vapor and then when I take my finger off the button the blue light just stays on for a few seconds. But when I take the tank off and push the button the light doesn't stay on like that.
  2. Is a G pen a type of E-cig? If so id say its probably a faulty battery.
  3. The heating element in your gtank isnt touching the battery, not hard to fix at all. Get some needle nose plyers and unscrew your gtank, theres a small metal cylinder in the screw on part of the gtank. it is fastened by a o ring, all you have to do is take the plyers and slightly pull the cylinder down(while twisting) so that the battery touches it while connected. ENJOY!
  4. Thanks bro. It still does it sometimes I just have to get the g tool and fuck with it inside where the bowl is and I can get it to work. Another problem I have tho is that one of the wicks is starting to come unwound and getting those little fiber things it's made out of everywhere. Im probably just gunna get a new tank anyways, but until then is this one still okay to use? And one more question, are yOu supposed to take out that little foam filter thing in the mouth piece?

  5. dont paye $25 bucks for a gtank thats bulls shit get it for $10 bucks on www.delta9vapes.com search for ego w under the empty cartomizer tab
  6. Ive tried everything and i cant find my receipt. Whenever i unhook the pen from the charger it stays lit until i plug it into the tank then whenever i push the button it lights up for a few seconds continuously then blinks thrice and stops???

  7. I had that problem too, u should see if there's a warranty on the battery. I just got a new vaporizer pen to replace my broken g-pen called The Ripper. Great for vaping straight oil and wax, no glycerine or cartridges to buy. No gtank or shitty cartomizer for vaping watered down glycerine concentrate, Just refill with oil/shatter/wax or other extract that burns clean and your off vapin ur bho/extract anywhere. Its my TI nail on the go, super easy to fill. They have chambers for straight oil/wax/budder/shatter for $20 with free 2 day shipping on website The Ripper Vaporizer | The most effective vaporizer pen on the market! Got a discount with coupon from their facebook

  8. I have the same problem!! also the pen wont heat up when i push the button and now has become useless. i have a glass tank and i tried using tweezers to pull the cylinder in the screw on tank down but it did not fix anything!! somebody please help!
    Just gonna give this a bump because I found this response very helpful. I've had my GPen for almost two months, had to recharge the battery twice so far and both times required this.
  10. Don't know if this helps anybody, but I was having a similar problem... Dead Battery? I thought so.. I screw on the charger but fail to get a red light, just stays green meaning fully charged I thought, but when I press the button and take a hit I get nothing... Then I found out that it has a lock... Press button 5 times til it blinks a few times.. In my case the pen was locked, I unlocked it and it seems to work fine now... Locking Feature ables one to store it in purse or pocket without accidentally igniting the tank. Hope this helps! (%
  11. Please help.

    I have a new gpen and it's not working. Whenever I try to hit it the smoke doesn't filter through and starts coming out the side. I cleaned the mesh filer and the mouth piece and the problem continues.
  12. Im having a problem with mine I got it yesterday and worked fine all day and into last night i drained the battery plugged it in and then when i went to use it this morning and the the button light blinks 5 times and the LCD lights up and reads 000 and the battery bar is full any ideas on how to fix this issue
  13. I have fixed mine! and it was wayyyyy easier than I thought. so under the heating coil is 2 small screws: one that is directly under the coil and the white saucer and the other is to the left and has a tiny wire coming out of it going to the coil. the small one on the left is the one you want to focus on. if you tighten that small screw it might fix your problems. i had an eyeglass repair screwdriver and I tightened it and it worked. Mine worked for 2 sessions out of the box before it had this issue and I was about to throw the damn thing against the wall but this made it work perfect. I attached a photo to see what screw i'm talking about. hope this helps.

    Attached Files:

  14. Just got the G pen and plugged it in to charge... After 30 mins of charging it starts flicking from red to green... Took the G pen out of the charger and clicked 5 times... Nothing, pretty sure when its fully charged it says green and doesnt go from red to green.
    Knew this product was gunna be a bunch of crap just like snoops best mate dre with headphones the same crap good marketing and packaging but absolutely rubbish product.
    help much appreciated!
  15. Thank you so much!! This solved my problem!!
  16. That piece of shit is not a fucking vaporizer. Throw that combusting bullshit out and get a real vape. Fuck you snoop Dogg and grenco science. Fuck you
    • Like Like x 1
  17. Its decent for a combustion pipe though
  18. It's still not a vaporizer. Post that bullshit somewhere else. There's too many of these fake vaporizer threads. Open them in the fucking dry piece section
  19. amen brother

    Sent from my SAMSUNG-SM-G900A using Grasscity Forum mobile app
  20. My g-pen works as stated, but it's still a crap gadget

Share This Page