problem getting vaporization

Discussion in 'Vaporizers' started by stewie77, May 1, 2016.

  1. Hi everyone. I just bought an Arizer V-Tower Vaporizer. This is my first time vaping so this is a noobie question. So I ground up the herb and put in the glass bowl and stamped it down so it's compact. I heard you don't want it too loose or it doesn't vaporize as good. I turned it up to 190 degrees Celsius and waited a minute for it to heat up. Then I started to inhale through the whip but was getting basically no vapor. I tried sucking harder by this caused all the weed to rise up in the bowl and scatter towards the top and I again got very little/no vapor. To be honest a few times I got a little vapor and I noticed that the weed had turned brown, which I heard means it vaporized the weed and I did get a small buzz. But later I didn't get it brown anymore. I used maybe 2 - 3 grams of weed, is that enough or does it matter how much you put in? I know your not going to get as much smoke as if you use a bong, but you are supposed to see a fair amount of vapor, right? I even turned it up to 250 degrees celcius to make sure I vaporized it and still virtually nothing. It's a digital vaporizer that shows the temperature, so I assume there's nothing wrong with the heating element. Does anyone know what I'm doing wrong? Thanks.
     
  2. Maybe try lightly packing the bowl, and make sure it's up to temp before use. Also, take long slow hits.

    Good luck!!

    dilligaf
     
  3. Heat up the bowl first then elbow pack your whip (screen where your whip connects to the bowl) and let the herb heat up a bit. This way when you draw on the whip you are basically concentrating the heat through the herb instead of around it in the cyclone bowl. I do it with the Extreme Q doing whips and bags and it works better that way. I usually pump the temperature higher than what I am aiming for because the sensor is closer to the element than the weed is. Hope that helps
     


  4. Also, it's not going to get hot enough in 1 minute.
     
  5. Let the element heat up for around 20 mins before putting the bowl on it.
     
Loading...

Share This Page