Grasscity - Cyber Week Sale - up to 50% Discount

Nute deficiency or nute burn?

Discussion in 'Sick Plants and Problems' started by GanjaGremlin, Jan 7, 2013.

  1. Hello, I have a 8 plant dwc hydroponic system, they are on the 7th week of flower. I'm using canna aqua nutrients a and b. is this a deficiency because I heard with canna nutes you need cal mag.
     

    Attached Files:

  2. You testing your PH?
    I had this same rusty looking leave issues with high PH.
     
  3. My ph is 5.9 which I heard is in the optimal range. Also my temp is at 65 and humidity is 40.
     
  4. There def looks like some N toxicity(dark green foliage w/ single and triple blade leaves) but I think you had some ph troubles earlier on as well that lead to the rust look. Since your far enough along, I look forward to the next grow. I'd start the nutes out at 25% less than you did with this grow and make sure to check your ph everyday.

    4th grow(Apprentice) - BC Big Bud 1200w
     
  5. You nailed that one on the head, it's surely a Mag def rearing its ugly face. Add some Epsom salt, keep PH around 5.9 for optimal uptake. GL
     
  6. Last two posters thank you so much!! I did have previous ph and nute problems at the beginning of grow. And thanks for the salt idea, looking forward to my next grow which will be a 18 plant one. Hopefully this new knowledge will let me hit the plants efficiently. Thank you do much guys!
    I would like your posts but I don't know how on my iPhone haha!
     
  7. Of go with calmag over Epsom salts though.

    4th grow(Apprentice) - BC Big Bud 1200w
     
  8. Help saliva Indian grow why is this happening
     

    Attached Files:

  9. You just posted that in a 4 year old thread
     
  10. I need help bout it bruh
     
  11. Try creating a new thread with more information on your grow like medium nutes lights temp humidity and so on and I'm sure alot more people will try to help you out man. Also add pics of the whole plant not just one leaf
     

Share This Page