MFLB not producing vapor?

Discussion in 'Vaporizers' started by fridgestar, May 2, 2011.

  1. i got my mflb today and tried it but its not producing vapor. i first thought it was the battery so i charged it for about 30 min to a hour and the charger went a solid green LED, so i took it out and tried again, with both batteries, no vapor. i put the batteries to charge again and the led is now blinking again despite me attempting to use the batteries for a couple of seconds with no successful result. can someone explain how this LED thing works? I thought that a solid green LED means that the entire battery is charged up..
  2. nevermind, found out that apparently i have to push the battery in a LOT to actually get it going
  3. Solid green on mine means it charged, red means charging, no flashing green ever occurred.

    But are you holding in the batter for 5-8 seconds, till you can see some vapor in the unit, then slowly inhaling while still holding it in.....??
  4. gotten the hang of it. this is pretty fucking great. conserves weed and gets me way higher than doing two full bowls compared to vaping .2g
  5. 2 hours to go and I get to pick up my mflb ordered it online realized they were in my city so I called them up and they are meeting me personally talk about service.
  6. Theres a couple of different possible chargers for it to ship with, mines a flashing green one, too. Its the charger with the MF logo on it.

Share This Page