Issue with Crafty - Please help :(

Discussion in 'Vaporizers' started by MikeMerriman, Apr 1, 2016.

  1. Hi all,

    I have a Storz and Bickel Crafty vape, up until yesterday it was working beautifully then all of a sudden it doesn't produce any vapor. The vape heats up fine and my herbs are being cooked as usual but I only get one hit before it stops producing anything else.

    The cooling chamber is completely clean as I meticulously cleaned it after this issue and still it persists.

    Highly frustrating as I'm burning all of my herb and not getting anything out of it.

    If anyone has had a similar experience it would be great to know how/if you fixed it. Or if anyone has any advice what so ever.

    Many thanks,
    Mike
     
  2. My best guess is poor quality herb or not dried/cured properly.
    Sometimes i get 10 - 15 hits sometimes 30 - 40. Depends on bud quality.

    Are you grinding up your herbs well and packing the chamber almost full and what temps are you using?
    I usually go for 185'C and when its green do a small hit then wait 5-10seconds and then start vaping.
     
  3. The thing is, it's the same herb as I usually use and I'm packing it the same as usual (about half full then using the liquid pad) Grinding very fine and using 365f the same as usual and it's worked great up to now.

    Literally one hit and then nothing
     
  4. #4 Wisdom Tooth, Apr 1, 2016
    Last edited: Apr 1, 2016
    Hmm.. that is strange indeed. Maybe the liquid pad is blocked? Try without it (a full chamber. Does it feel as hot as usual when heated up? Try higher temps too.

    Hows the taste? sometimes there is light or no vapor but you still can get high until you start noticing the "rotten/burnt taste" telling you the herb is pretty much done.
     
Loading...

Share This Page