is this definetely a mag deficiency?

Discussion in 'Growing Marijuana Indoors' started by yoloweedo, Aug 11, 2019.

  1. after getting this problem i used epson salts as a feed and foilar spray. the symptoms got slightly worse but i was expecting that with it taking afew days to show. i think the marks have stopped spreading now but im not completely sure. im going to feed just base this next week to help also. im just worried that after all this its not a mag deficiency at all and its something else...

    my ph run off is 6.1
    ec 1.3

    lights are 400w hps 35 - 40cm away from aircool glass giving about 27k lux on each top[​IMG][​IMG][​IMG][​IMG]

    Sent from my Redmi 4X using Tapatalk
     
    • Like Like x 1
  2. download.jpg ive seen leaves like that with pH trouble ,heres a picture of some leaves showin pH trouble,,but some one here at GC maybe able to put you right ,,mac,
     
  3. thanks mac i dont think its the ph though as i keep checking it everytime i water but i will definitely keep an eye on it. i think i may have overdone it with pk to be honest and now ive cut down the base to get rid of the tox these problems have showed up.. i just hope raising the base fixes all my problems

    Sent from my Redmi 4X using Tapatalk
     
    • Like Like x 1
  4. i dont really know much about pH mate( ive never pHd the water) i just had the picture in my files etc,,but i think your 6.1 is ok ,but whats the pH of the water you use ,,,,mac,
     
    • Like Like x 1
  5. i see pal well thanks for looking through your stuff for me anyway. i do appreciate it :D but yer i think 6.1 is good really. ive been feeding 6.0ph throughout letting the ph go up to 6.1 or down if it does go down. but i always check it before i feed. since this deficiency ive been giving them 6.2 because cal mag is absorbed better at that level.

    Sent from my Redmi 4X using Tapatalk
     
  6. before nutrients and phing the water is about 7 - 7.5ph
    ec is 0.2

    Sent from my Redmi 4X using Tapatalk
     

Share This Page