How to tell if HPS grow light is dead?

Discussion in 'First Time Marijuana Growers' started by safiel, May 19, 2006.

  1. I'm an utter newbie. I bought a grow light for my first grow from Inside Sun. The 400 watt. The ballast hums when plugged in but the bulb wont power on. I am clueless how to troubleshoot this. I don't know if something I, in my newbiness, need to do or if the bulb or ballast are defective. All I need was screw in the bulb and plug the thing in. Anyone have any advice?
     
  2. How long are you letting it stay on? I'm not trying to imply anything by making a really simple suggestion, but you know that HID lights warm up a bit first, right?
     
  3. I thought they took a couple of minutes. I had it running for about 20-30 mins.:(
     
  4. switch out the bulb. If it lights, it was the bulb. If it don't, then it's teh ballast (or you have two bad bulbs :D)
     
  5. if that thing was humming for 20 minutes on a bad bulb, I'll bet you dollars to doughnuts that you burned out your ignitor.
     
  6. Sigh. If I had another bulb to try, I would. Bluh. Hate it when you order stuff that is DOA.
     
  7. I bought the same thing from insidesun.com and mine is working fine. If the ballast is humming it sounds like a bulb problem to me. You can get 400w hps bulbs from home depot. Thats my two cents
     

  8. Call the guy at Inside Sun on the telephone. His name is Michael and he is very helpful.
     
  9. my ballast gives of a hum and it takes about 2 min to fully light my light. it must be the bulb? if not its the ballast sdo what they say get another bulb and test it
     

Grasscity Deals Near You

Loading...

Share This Page