Help with Eureka oil cartridge!

Discussion in 'Vaporizers' started by JennyFromTheBong, May 2, 2016.

  1. Hey everyone! So yesterday I got a Eureka CO2 cartridge and threw that shit on a regular little 510 battery for like blu or some shit. At first it was hitting great, but now it seems the connection plates (battery &a cartridge) are not making contact. When I try to take a pull it lights up, but I get no vapor. I tried googling other fixes but it seems the only way to fix this is to unscrew the cartridge and lift the connection plate a little bit. Problem is that only works for 1-2 hits and then I get the same problem.

    What can I do about this? It's really fucking annoying to have to unscrew the battery and shit every time I want to get loaded! Any other means of smoking this oil?

    Also, I tried it on the variable voltage battery I use for my Kiln and it works fine, but the cartridge gets REALLY hot. I read that I could burn it out using high voltage so I'm trying to avoid this route.

Share This Page