1. Win a $250 shopping spree at Grasscity.com! To enter subscribe to our youtube channel.
    Dismiss Notice

Help me with my car problems!!!!

Discussion in 'General' started by cowofsteel, Sep 23, 2003.

  1. Okay, I just bought a 92 Chrystler LaBaron from a good friend of mine. It has 130,000 miles on it (yea i know thats a lot). It was running fine, until about a week ago. Almost everytime I come to a complete stop, the car jerks really really bad after I stop. What I think is happening is its switching from 2nd to 1st after the car has stoped. is that even possible? I can't get the mechinac to fix it, everytime somebody like my dad or the mechnic rides in it, it doesn't do it.
    Like ten minutes ago, I was driving around and it was doing that everytime i stoped, literaly everytime, so i got my dad real quick, we go for a spin, and IT DIDN"T DO IT AT ALL! i was so mad, its never going to get fixed.

    The mechnic says it might be the tranmission air filter, but i have no idea.

    Any blades gots a clue?
     
  2. its all good, just looking for some help here... its really starting to piss me off
     
  3. when you say.....when you stop, do you mean at lights etc, or when you have stopped and switched the engine off?........Peace out.......Sid

    ps i take it it's an automatic?
     
  4. If it is an automatic trans, you made need to change the trans filter... It really doesn't sound like a trans problem to me though.. Automatics usually quit pulling on hills or the trans just slips..


    It sounds more like the car is running rough.. Do you hear wierd sounds when it does it???
     
  5. ^ wow, so that could be the transmission filter? never thought that could cause such a problem, although the thing has never been changed on a car with 135,000 miles.



    BH - also, yes it is automatic
    no there arn't any noisies that worry me

    Sid - its when i stop at a stop sign, not when i turn the car off

    and one more then, when i try to go after slowing down to like under 5mph, the car doesn't catch right away. Its reeves first, then catches, but only somtimes again

    sorry if im explaining this horribly, i don't know jack about cars


    THANKS FOR ALL YOUR HELP!
     
  6. Run away from that grease monkey. It's not the transmission filter its the transmission. Its in limp mode. Don't have it rebuit, don't put in a salvage. If you are intent on keeping this P.O.S. put in a factory rebuit transmission, its a tad bit more expensive but it comes with a 3/36 warranty and its rebuit with updated parts from Chrysler. If it has a 3.0liter motor I would sell it now!! Hmm let me guess does it smoke out the pipe on start up? Valve guide seals if not shot already they will be soon. If its a 2.5 keep it and repair the oil leaks every couple of months. If you want to know how much this transmission should REALLY cost you let me know.

    Any other chrysler questions?
     


  7. You might as well check on getting a new trans or rebuilt one..



    and one more then, when i try to go after slowing down to like under 5mph, the car doesn't catch right away. Its reeves first, then catches, but only somtimes again

    The trans is slipping!!!!!^^^^^^
     
  8. damn, this sucks
     
  9. It could always be worse my friend....


    Just think possitive and m,aybe it won't be that expensive!
     

Grasscity Deals Near You

Loading...

Share This Page