First Real Grow - Leaf Issues

Discussion in 'Sick Plants and Problems' started by D3scr1beM3, Jul 27, 2019.

  1. Hey everyone!

    First time posting here after lurking for a while. I’ve started a new grow after not having done it in a very long while, and also trying outdoors which I’ve never done. I grow plenty of other plants, fruits and veggies, but this is new territory for me.

    I added a few pictures of my girl here, just tryin my hand at a single plant until I can get back into the groove.

    Some info about it:
    Medium: Organic soil from local nursery (I’ll be switching to Roots Organic with the next one.)
    Where: Outdoors (Central FL area)
    Strain: Cheese Auto Flower
    Age: Sprouted around June 1st
    Water Freq: It’s rained close to every day here lately so I haven’t watered it personally.
    Nutes: Unfortubately I didn’t have the option of getting veg/flower specific nutes for this one. But I used Mycorrhizae when it started, use Thrive Alive with some waterings and tomato plant nutes (rarely). Also earth worm castings with the soil.
    Preventative//Insecticide: Dyna Gro Neem Oil

    The issues almost look like sun burn to me as it’s been REALLY hot here plus rains at least once a day usually. I’m just not sure at all since the one picture shows some yellowing/yellow spots but now it’s more burn spots than anything.

    Let me know if y’all need more info or pics, I’d be happy to provide that.

    Any help is greatly appreciated!!

    Edit: Forgot to mention, I took these pictures in early morning so that’s why they’re wet/covered in dew.
     

    Attached Files:

  2. Hello!

    Took a few more pics today. Went in a trimmed some of the dead off, I’m just hoping she is still save-able. Worried it may have been mold since it’s been so wet/rainy out lately?

    Any help with this is really appreciated, I feel like it may be too late and I’ll ya w to chop her dish and start over.
     

    Attached Files:

Share This Page