Grasscity - Black Friday Sale - up to 70% Discount

6 weeks into flowering, mold problem, lost cause?

Discussion in 'Sick Plants and Problems' started by wretched4one, May 28, 2010.

  1. Been battling the mold/mildew problem with sulfur burner and milk/water spray. Should probably not use sulfur anymore being this close to harvesting. Would moving them outside help any for the last 2 weeks? It is suppose to be in the 80's for the next two weeks and probably longer. Any suggestions would be appreciated.
     

    Attached Files:

  2. Hard to tell if that is mold in the pics but will trust you to know that it is :)

    Have you checked and adjusted your humidity?
    Have you got an oscillating fan blowing across your plants?
    Are you over-watering? Every time you water you add more moisture to the air so it's another reason to let the soil dry out between watering.

    Plants (in general not just MJ) that haven't been outside in real sunlight often suffer from shock when you move them from inside to outside so if you are going to put them outside you need to start it off very slow. So if you want to do that, then put them out for a couple hours of indirect sunlight for a couple days then start increasing the time and sun exposure every couple days until they get acclimated.
     
  3. Thanks for info. Humidity is normally bellow 50%. Only water when top 2 inches are dry. Temps during the day are around 75 and then 65 at night. Have plenty of fans in room. Will continue with sulfur burn and will raise room temp to 90 last 2 hours of lights on. Continue with milk/water spray during beginning of lights on.
     
  4. putting it outside may help but don,t let her get rained on
    go to the store tell them you have a plant tomato with mold
    they should have something to kill it
    good luck :smoking:
     
Loading...

Share This Page